Excel: Chyba při dělení nulou

Chaoticum aktualizoval

Pokud se v Excelu pokoušíte dělit nulou, uvidíte v buňce s výsledkem chybu #DIV/0!. Jak tuto chybu opravit pomocí jednoduchého řešení?

Řešení: Je nutné použít podmínku. Ukázkový vzorec =A2/B2 stačí změnit například na =IF(B2=0;B2;A2/B2). V české verzi excelu =KDYŽ(B2=0;B2;A2/B2).

Vysvětlení vzorce:

=IF( B2=0; B2; A2/B2)
pokud je hodnota v buňce B2 rovna 0 vlož hodnotu buňky B2 jinak vlož výsledek dělení buněk A2 a B2

Ukázka chybného vzorce

Vzorec: =A2/B2

Hodnota 1 Hodnota 2 Výsledek
6 0 #DIV/0!

Chyba #DIV/0! při dělení nulou v Excelu

Ukázka správného řešení

Vzorec: =IF(B2=0;"chyba";A2/B2). Místo "chyba" můžete použít například B2 nebo 0 nebo libovolnou jinou hodnotu. Záleží jaký výstup potřebujete získat.

Hodnota 1 Hodnota 2 Výsledek
6 0 chyba

Správné řešení při dělení nulou v Excelu

Byl pro Tebe obsah užitečný? Nenechávej si to pro sebe a sdílej!
  •  
  •  
  •  
  •  
  •  
  •  

Napsat komentář

Vaše emailová adresa nebude zveřejněna. Vyžadované informace jsou označeny *